Эта статья также доступна на:
В этой статье мы поговорим о том, как мы можем разрешить более старым и / или более новым версиям игры присоединяться к вашему серверу minecraft! Например, если у вас есть свой сервер в 1.18.2, но вы хотите разрешить игрокам с 1.12.2, это возможно! На самом деле, также возможно разрешить игрокам 1.18.2 присоединяться к серверу 1.12.2! Вы можете пригласить игроков вплоть до 1.7.x присоединиться к вашему серверу.

Все это достижимо с помощью плагинов под названием ViaVersion, ViaBackwards и ViaRewind. Мы рассмотрим каждый плагин и то, что они делают!

ViaVersion

ViaVersion позволяет новым версиям игры присоединяться к более старой версии сервера minecraft. Это также обязательный плагин для установки, если вам нужно использовать ViaBackwards и ViaRewind.

Вот наглядное представление версий, которые могут подключаться к вашему серверу



Установка

Загрузите плагин здесь . Загрузите плагин в свою папку plagins и перезапустите сервер. С тобой покончено!

Конфигурация

Настройка этих плагинов не так уж сложна. Это всего лишь простое перетаскивание! Вот основные моменты из наиболее важных параметров конфигурации, которые вы можете найти в config.yml
block-versions - используйте это, если вы хотите запретить определенным версиям подключаться к вашему серверу. Например, если я хочу заблокировать все, что меньше 1.13.2, это будет [<1.13.2]. Если бы я хотел заблокировать 1.13.2 и 1.16.5, это было бы [1.13.2, 1.16.5] и так далее
Исправления - Вы обязательно столкнетесь с проблемами с голограммами, лодками, виноградными лозами и т.д. из-за проблем с перекрестной совместимостью. Вы можете проверить конфигурацию этих параметров, чтобы включить / отключить их. Чтобы получить подробные пояснения к конфигурации, перейдите по этой ссылке



ViaBackwards

ViaBackwards позволяет старым версиям (вплоть до 1.9.x) игры присоединиться к более новой версии сервера minecraft. Чтобы это сработало, у вас также должна быть установлена ViaVersion

Вот наглядное представление версий, которые могут подключаться к вашему серверу



Установка

Загрузите плагин с здесь . Загрузите плагин в свою папку plugins и перезапустите сервер. С тобой покончено!

Конфигурация

Конфигурация ViaBackward коротка и очень понятна. Смотрите на прилагаемом рисунке ваши параметры для настройки. Выделенный серым цветом текст содержит пояснения к тому, что делает каждый параметр конфигурации!



ViaRewind

ViaRewind позволяет версиям младше 1.9.x ( 1.7.x-1.8.x ) присоединяться к более новой версии сервера minecraft. Чтобы это сработало, у вас должны быть установлены ViaVersion и ViaBackwards

Вот наглядное представление версий, которые могут подключаться к вашему серверу



Установка

Загрузите плагин с здесь . Загрузите плагин в свою папку plugins и перезапустите сервер. С тобой покончено!

Конфигурация

Конфигурация ViaRewind коротка и очень понятна. Смотрите на прилагаемом рисунке ваши параметры для настройки. Выделенный серым цветом текст содержит пояснения к тому, что делает каждый параметр конфигурации!



Статья, сделанная виджайпондини#0001 ( ID 631466030023049217 )
Была ли эта статья полезна?
Отменить
Спасибо!