This article is also available in:


Panimula

Minsan, para mag-compile ng mga JAR ng plugin, magpatakbo ng mga mas lumang bersyon ng minecraft, at iba pa, kailangan mo ng mga bersyon ng java na may iba't ibang uri. Sa artikulong ito, ipapaliwanag namin kung paano mag-install ng iba't ibang bersyon ng java at itakda kung aling bersyon ng java ang gagamitin ng system!


☕ Pagda-download ng iba't ibang Bersyon ng Java ☕

Para sa gabay na ito, gagamitin namin ang Eclipse Temurin para sa mga bersyon ng Java. Mag-i-install kami ng java 8. Pumunta sa https://adoptium.net/temurin/releases/ , at piliin ang mga sumusunod na opsyon

Windows bilang iyong operating system
Package type bilang JDK - JRE hindi gagana para sa pag-compile ng mga plugin o pagpapatakbo ng laro sa bersyon ng java
Architecture bilang x64 - karamihan sa mga system ay x64, tingnan kung kailangan mo ng x32 sa pamamagitan ng pagsuri sa impormasyon ng iyong system sa control panel
Version bilang 8 , para mag-install ng Java 8 - pumili ng ibang bersyon kung gusto mong mag-install ng ibang bersyon



I-download ang .msi file mula sa site, at buksan ito. Hayaan itong i-install ang java software nang naaayon. Huwag mag-isip ng anumang mga pagpipilian maliban kung alam mo kung ano ang iyong ginagawa. Kapag tapos na, na-install mo na ang partikular na bersyon ng java na iyong pinili!

Ang mga file para sa Java mismo ay makikita sa C:\Program Files\Eclipse Adoptium , at batay sa iba't ibang mga bersyon, magkakaroon ka ng mga folder tulad ng jdk-17.0.1.12-hotspot para sa java 17, jdk-8.0.332.9-hotspot para sa java 8, at iba pa. Kilalanin ang tamang bersyon ng java sa pamamagitan ng mga unang numero!


📂 Gamit ang isang partikular na bersyon ng java 📂

Upang tukuyin ang isang tiyak na bersyon ng java na gagamitin, kakailanganin naming i-edit ang mga variable ng kapaligiran sa iyong PC. Upang gawin ito, magsimula sa pamamagitan ng pagbubukas ng Windows Run ( gamit ang Win + R o sa pamamagitan ng pag-type ng "Run" sa search bar).
Pagkatapos, i-type ang sysdm.cpl at i-click ang OK. May lalabas na window. Sa window na iyon, pumunta sa advanced, at mag-click sa "Environment Variables"



Kapag nabuksan, hanapin ang seksyon ng mga variable ng system. Dito, hanapin ang variable na JAVA_HOME. Piliin ito, at i-click ang Edit. Susunod, kailangan mong piliin ang folder kung saan naka-install ang bersyon ng java. Mag-click sa "Browse Directory" at mag-navigate sa Program Files --> Eclipse Adoptium --> Piliin ang folder ng bersyon ng java na gusto mong patakbuhin, at i-click ang OK kapag napili.



Sa ating kaso, ang variable na halaga ay C:\Program Files\Eclipse Adoptium\jdk-8.0.332.9-hotspot . Panatilihin ang pag-click sa OK sa lahat ng mga bukas na window hanggang sa sarado ang window ng system properties.

I-verify na ginagamit mo ang tamang bersyon ng java sa pamamagitan ng pagbubukas ng command prompt at pag-type java -version . Sa ating kaso, sinasabi nito ang Java 8, tulad ng inaasahan!

openjdk version "1.8.0_332"
OpenJDK Runtime Environment (Temurin)(build 1.8.0_332-b09)
OpenJDK 64-Bit Server VM (Temurin)(build 25.332-b09, mixed mode)



🎮 Pagpili ng bersyon sa iyong minecraft launcher 🎮

Upang baguhin ang bersyon ng java na ginamit sa laro ng minecraft, buksan ang launcher ng minecraft. Pagkatapos, pumunta sa tab ng mga pag-install sa itaas. Mag-click sa 3 tuldok sa pag-install na gusto mong i-edit, at i-click ang I-edit.

Mag-scroll pababa, pindutin ang "More options" at pagkatapos ay i-click ang "browse" sa Java executable field upang pumili ng java na bersyon na iyong pinili. Sa kasong ito, kakailanganin mong piliin ang javaw.exe file, na karaniwang naroroon sa java folder (tulad ng`jdk-8.0.332.9-hotspot` ) --> bin --> javaw.exe . Kapag napili, i-click "Open", at pagkatapos ay i-save ang iyong pag-install. Mapipili mo ang bersyon ng java na gusto mong tumakbo para sa minecraft




Konklusyon

Alam mo na ngayon kung paano pumili kung anong bersyon ng Java habang nagko-compile ng mga plugin, server software, o naglalaro ng minecraft sa iba't ibang bersyon!
Was this article helpful?
Cancel
Thank you!