This article is also available in:
In this article, we'll talk about how we can allow older and/or newer versions of the game to join your minecraft server! For example, if you have your server in 1.18.2, but want to allow players from 1.12.2, it's possible! In fact, it's also possible to allow 1.18.2 players to join on a 1.12.2 server! You can have players all the way down to 1.7.x to join your server.

All of this is achievable with a family of plugins called ViaVersion, ViaBackwards, and ViaRewind. We'll go over each plugin and what they do!

ViaVersion

ViaVersion lets newer versions of the game join an older version minecraft server. It is also a required plugin to install if you need to use ViaBackwards & ViaRewind.

Here's a pictorial representation of the versions that can join into your server



Installing

Download the plugin from here . Upload the plugin into your plugins folder, and restart the server. You're done!

Configuration

There's not a lot to configuring these plugins. It's just a simple drag and drop experience! Here are highlights from the most important config options you can find in config.yml
block-versions - Use this if you want to deny certain versions from joining your server. For example, if I want to block everything lesser than 1.13.2, it would be [<1.13.2]. If I wanted to block 1.13.2 and 1.16.5, it'd be [1.13.2, 1.16.5] and so on
Patches/fixes - You are bound to run into issues with holograms, boats, vines, etc. due to cross-compatibility issues. You can check the config for these options to enable/disable them. To get detailed explanations for the configuration, visit this link



ViaBackwards

ViaBackwards lets older versions ( down to 1.9.x ) of the game join a newer version minecraft server. For this to work, you must have ViaVersion installed as well

Here's a pictorial representation of the versions that can join into your server



Installing

Download the plugin from here . Upload the plugin into your plugins folder, and restart the server. You're done!

Configuration

ViaBackward's configuration is short and very self-explanatory. See in the attached picture for your options to configure. The grayed out text contains explanations to what each config option does!



ViaRewind

ViaRewind lets versions under 1.9.x ( 1.7.x-1.8.x ) to join a newer version minecraft server. For this to work, you must have ViaVersion and ViaBackwards installed

Here's a pictorial representation of the versions that can join into your server



Installing

Download the plugin from here . Upload the plugin into your plugins folder, and restart the server. You're done!

Configuration

ViaRewind's configuration is short and very self-explanatory. See in the attached picture for your options to configure. The grayed out text contains explanations to what each config option does!



Article made by vijaypondini#0001 ( ID 631466030023049217 )
Was this article helpful?
Cancel
Thank you!